Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: moves and counts.

  • In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
  • In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题解:

                并查集,并记录i元素上面和下面的元素个数

#include <cstdio>
#include <cstdlib>
#include <cstring>
const int N = 30005;
int set[N];
int high[N]; //i元素上面(加上i)的元素个数 
int low[N];  //i元素下面的元素个数 
int findset(int x){
    if(x == set[x])
        return set[x];
    int tm = set[x];
    set[x] = findset(set[x]);
    low[x] += low[tm];
    return set[x];
}
void unionset(int x,int y){
    int fx = findset(x);
    int fy = findset(y);
    if( fx == fy)
        return ;
    set[fx] = fy;
    low[fx] += high[fy];
    high[fy] += high[fx];
}
int main(){
    int n;
    while(scanf("%d",&n) != EOF){
        for(int i = 1; i <= N; i++){
            set[i] = i;
                 high[i] = 1;
        }
        memset(low,0,sizeof(low));
        char op;
        int x,y;
        getchar();
        for(int i =1 ; i <= n; i++){
            scanf("%c",&op);
            if(op == 'C'){
                scanf("%d",&x);
                findset(x);
                printf("%d\n",low[x]);
            }
            else{
                scanf("%d%d",&x,&y);
                unionset(x,y);
            }
            getchar();
        }
    }
    return 0;
}









blog comments powered by Disqus

Published

2013-04-09

Categories


Tags